Compiling and building projects


Writing code

When you write code in a Module, or in the editor of a window object for visual projects, all variables, structures, macros and procedure names are stored in the Properties window. They are divided in two groups:

Macros and Procedures
Structures and Variables

The combo box located over the Properties window, allows you to change from a group to another. To go to the code related to a Procedure, Structure, Macro or Variable, just click on its name inside the Properties window. If some Proc, Macro, Struct, etc., has been added or deleted, and its name is still in the Properties window (or it is missing), press the <F10> key, or use the Tools-->Refresh <window name> menu, while the focus is in the code editor, and the entire Properties window will be updated.

In visual projects the Properties window contains all mentioned names when the code editor of an object is visible or when a Module is the active object (it is always visible for classic projects as they only have modules). When an object is active and its code editor is not visible, the Properties window of the object is displayed instead. Then, the combo box located over the Properties window lets you change among child controls inside the window object.

All files needed for building a project, including those necessary files for Windows applications (Windows.inc, kernel32.lib, user32.lib, etc.), should be added to project through the Easy Code interface (better than including them in the code) using the following menus:

Include files (*.inc) Use Project-->Add Include files (*.inc;.h) menu
Library files (*.lib) Use Project-->Add Library files (*.lib) menu
Compiled resource file (*.res) Use Project-->Add external resources (*.res) menu
Definition file (*.def) Use Project-->Add Definition file (*.def) menu


Using Rich Edit and Common controls

Checking/unchecking these two options in the Project properties will cause the corresponding buttons to be shown/hidden in the tool box.

Only when working with visual projects, checking any of these options will make Easy Code to add and initialize the corresponding controls.


REMARKS:
In classic projects, the Comon controls and RichEdit options, in the
project properties, just add or remove the buttons in the tool box. If you have to use any of them, you must include the corresponding inc and lib files.


Compiling and building projects

    Inside the menu Build you will find the following submenus:

       Compile <Module name> (Ctrl+F7)

Compiles  the active window or module.

        Build <Project name>.<extension> (F7)

Compiles the windows or modules that have been modified and builds the project.


        Rebuild
all

Compiles all windows and modules (modified or not) and rebuilds the whole project.


        Test
<window name(Shift+F5)  (Only available for visual projects)

Allows you to test the active window in order to see its final appearance. No code is processed when testing a window, but you can check menus and string resources and navigate through child controls checking its tab order. This option is only available for visual projects.


        Debug
<Project name>.exe (F5)  (Only available for executable files)

Allows you to run a debugger with the built executable file (if any). When it was built in Debug mode, the executable file debugged is that located in the Debug directory. If not, the executable file debugged is that located in the Release directory. This option just loads the debbuger (its path has to be specified in menu Tools->Settings), but has no control over it.


        Run
<Project name>.exe (Ctrl+F5)  (Only available for executable files)

Allows you to run the built executable file (if any). When it was built in Debug mode, the executable file started is that located in the Debug directory. If not, the executable file started is that located in the Release directory


In the bottom part of the IDE you can see the output window (if it is hidden, it is shown when compiling and or linking) 
which can be shown/hidden by pressing the <F8> key. This window shows all errors returned by the compiler (ml.exe) and the linker (link.exe). By double clicking on an error line of the output window, you will directly go to the afected line in the code.


IMPORTANT
: As Easy Code compiles its projects with the
assembler specified in the Tools->Settings menu, the correct syntax when writing code must be that needed for the specified assembler. The examples coming with Easy Code have been programmed for the Microsoft's ml.exe assembler and the Link.exe linker.