Settings menu - Configuring Easy Code


Available through the Tools-->Settings menu. It displays the following window:


General Tab



Editor Tab

Includes several options allowing you to customize the editor.

Code colors

Font

Tab size (spaces)

Line format correction

Show line nubers

Automatic indentation

Keywords syntax correction

Auto variable info

Auto parameter info

Constants and variables info

Enable syntax highlighting

Colorize API constants and structures


REMARKS: In some old slow computers, it is possible that the editor scrolls slowly. If so, try to uncheck the Colorize API constants and structures option.



Compile / Link Tab

In the Executable files for building applications section, you have to enter the following files (placed in the bin folder created by Masm32 or GeneSys packages):

Compiler The path to a compiler file (ml.exe recommended)
Linker The path to a linker file (link.exe recommended)
Resource compiler The path to a resource compiler file (rc.exe recommended)
Library compiler The path to a library compiler file (lib.exe recommended)

while in the Directories for Include, Library, Macros and Help files section, you have to enter the path for Include, Lib, Help and Macros folders (placed in Masm32 or GeneSys folders), respectively. In both cases, if those paths are not properly set, errors will be generated at compile or link time and the project will not be built.

The path specified in Macro files will be used to include the Macros.asm file at compile time (only if the Macros.asm file option in Project->Properties is checked), while the path specified in Help files (only available in Masm32) is used to open the help files for Masm32 Reference, Masm32 Library and Opcodes, in the Easy Code Help menu.


Tools Tab